SSL certificate problems affecting some sites
Incident Report for Netlify
Resolved
All but a handful of certificates have been renewed, and Let's Encrypt have posted (https://community.letsencrypt.org/t/revoking-certain-certificates-on-march-4/114864) that no certificates will be revoked until midday tomorrow - by which point we should have the remainder of certificates renewed. Please post in our community thread here if you have follow-up questions: https://community.netlify.com/t/lets-encrypt-certificate-revocations-3-4-march-2020/9945
Posted Mar 03, 2020 - 21:56 PST
Update
All but a few hundred affected certificates have been renewed; our team continues to work on the remaining sites.
Posted Mar 03, 2020 - 21:36 PST
Update
We are continuing to monitor for any further issues.
Posted Mar 03, 2020 - 19:16 PST
Update
We are continuing to monitor for any further issues.
Posted Mar 03, 2020 - 16:07 PST
Monitoring
Let's Encrypt is revoking many SSL certificates, and while our team has been working very hard to renew all impacted certificates in the 10 hours since we were informed that this would happen (see https://community.netlify.com/t/lets-encrypt-certificate-revocations-3-4-march-2020/9945 for details), we have not yet managed to renew several thousand certificates, which we are still working hard to renew. Your site may see downtime depending on when Let's Encrypt begins revoking, which was scheduled to happen at midnight UTC - though the timing could be later.
Posted Mar 03, 2020 - 16:03 PST
This incident affected: Content Distribution Network.