Issue with domain registration renewals

Incident Report for Netlify

Resolved

We have identified an issue affecting domain renewals for some accounts where payment methods need to be updated. Affected customers have been notified via email with instructions to update their payment information
Posted Jan 16, 2026 - 01:13 UTC

Investigating

We are currently investigating an issue that is preventing the renewal of some domains for accounts with payment methods that have not been updated recently.
Posted Jan 15, 2026 - 22:33 UTC
This incident affected: Billing.