Delayed email notifications
Incident Report for Netlify
Resolved
The issue with email delivery delays is now resolved. If you experience any further issues receiving emails from our service, please contact our support team using https://www.netlify.com/support/.
Posted 3 months ago. Jun 25, 2019 - 20:23 PDT
Monitoring
New email notifications are being delivered in real-time, and our backlog is being processed as fast as possible, but this work may not complete for a few hours. We'll resolve this incident when the backlog is empty.
Posted 3 months ago. Jun 25, 2019 - 15:37 PDT
Identified
Emails from Netlify's app are arriving with a delay of up to several hours, and some less essential notifications are being limited. We are working with our mail provider to fix the situation, but we do not anticipate an immediate fix. This affects signup, password reset, invitation, and billing emails in addition to email notifications about builds and form submissions. Notifications via webhook, Slack, Zapier, and notifications sent directly to your git provider such as PR comments are not affected, and will be delivered in real time.
Posted 3 months ago. Jun 25, 2019 - 08:46 PDT
This incident affected: API.