Increased errors on High Performance Edge in Mumbai region

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 04:17 UTC

Investigating

We're investigating an increase in errors on the High Performance Edge Network in Mumbai (BOM) region since 3 AM UTC.
Posted Mar 12, 2026 - 03:43 UTC
This incident affected: High-Performance Edge Network.