Increased errors on Netlify Image CDN

Incident Report for Netlify

Resolved

Image delivery performance has stabilized, and performance has returned to normal levels. We are no longer observing elevated error rates.
Posted Jan 13, 2026 - 18:38 UTC

Monitoring

A fix has been implemented, and we are seeing signs of recovery, performance is improving. We are continuing to monitor closely and will provide further updates as needed
Posted Jan 13, 2026 - 18:19 UTC

Identified

We've identified the cause of the elevated error rates affecting our image CDN. Mitigation efforts are underway, and we're monitoring for improvements.

We’ll continue to provide updates as we make progress.
Posted Jan 13, 2026 - 17:40 UTC

Investigating

Starting around 17:00 UTC we're seeing an increase in errors on Netlify Image CDN. We're investing the issue.
Posted Jan 13, 2026 - 17:23 UTC
This incident affected: Netlify Image CDN.