Failure to deploy sites due to function upload failure

Incident Report for Netlify

Resolved

Between 15:20 UTC and 16:30 UTC we saw build failures for builds with functions. The incident has been resolved, and we are no longer observing any issues. Thank you for your patience.
Posted Dec 08, 2025 - 17:40 UTC

Monitoring

We have deployed a fix to our functions deployment pipeline and are currently monitoring the results.
Posted Dec 08, 2025 - 16:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 08, 2025 - 16:08 UTC

Investigating

We're seeing failures to deploy sites (sites what have functions) due to a failure to upload functions. Our team has identified the issue and is working on a fix.
Posted Dec 08, 2025 - 15:54 UTC
This incident affected: Build Pipeline.