Delayed Builds on Free Accounts

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 01:25 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Mar 03, 2026 - 01:14 UTC

Investigating

Beginning at 23:58 UTC, we began seeing an increased rate of delayed builds for plans on the Free tier. We are currently investigating this issue.
Posted Mar 03, 2026 - 00:51 UTC
This incident affected: Build Pipeline and Collaborative Deploy Previews.