Increased function failures on the self-serve CDN
Incident Report for Netlify
Resolved
Our fix has resolved the issue; no actions are needed by our customers. We do not expect recurrence but our team will continue to monitor.
Posted Feb 22, 2022 - 18:13 UTC
Monitoring
We completed a rollback of the component that caused this issue and there should be no more impact on serving your sites. We will keep monitoring to ensure our fix is complete and stable.
Posted Feb 22, 2022 - 17:58 UTC
Identified
Our team is still working on a fix for this issue which affects only customers using our self-serve CDN, not our High Performance CDN. This will only affect function invocations that depend on the event.rawUrl parameter, as this issue is ongoing we are wrongly sending a relative instead of an absolute URL, which could produce error responses from your function. This would particularly affect you when using frameworks that use SSR (e.g. NextJS, Gatsby, Remix and others) on Netlify.
Posted Feb 22, 2022 - 17:48 UTC
Investigating
Our team is investigating increased function failures on the regular CDN.
Posted Feb 22, 2022 - 17:37 UTC
This incident affected: Netlify Functions.