We’ve identified the root cause of the environment variables issue affecting some sites and have deployed a fix. The fix is now live, and impacted sites should have automatically received it. Customers do not need to take any further action.
We’ll keep monitoring our channels for any additional reports. If you continue to experience issues, please contact support.
Posted Mar 30, 2026 - 19:38 UTC
Update
We've identified the issue and applied a fix. No new sites are affected by the issue and we are applying a fix for previously affected customers.
Posted Mar 30, 2026 - 12:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 30, 2026 - 11:20 UTC
Investigating
We are investigating an issue where environment variables were not being read at runtime for some sites. We will provide an update shortly.
Posted Mar 30, 2026 - 08:48 UTC
This incident affects: Build Pipeline, Netlify Functions, and Edge Functions.