Domain Purchasing Issues

Incident Report for Netlify

Resolved

This incident has been resolved, and domain purchasing is fully restored.
Posted Nov 14, 2025 - 11:28 UTC

Monitoring

A fix has been implemented and domain purchasing is available again. We will actively monitor.
Posted Nov 14, 2025 - 11:14 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 14, 2025 - 10:22 UTC

Identified

We have identified the issue, and are working on putting a fix in place. Domain purchasing is still disabled while we resolve.
Posted Nov 14, 2025 - 09:27 UTC

Investigating

Since 11:30pm UTC on 11/13, domains have been experiencing issues in completing registration. As of 7:15am UTC, domain purchasing is unavailable while a solution is put in place.
Posted Nov 14, 2025 - 08:45 UTC
This incident affected: Domain Purchasing.