Increased latency in Image CDN

Incident Report for Netlify

Resolved

Latency has returned to normal levels. This incident is resolved.
Posted Jun 11, 2025 - 14:37 UTC

Monitoring

Latency and error rates have returned to normal levels, and we are now observing the system to ensure continued stability.
Posted Jun 11, 2025 - 14:05 UTC

Identified

We have identified the cause of the latency and are working towards a fix.
Posted Jun 11, 2025 - 13:22 UTC

Investigating

We are currently investigating reports of issues with our ImageCDN.
Posted Jun 11, 2025 - 13:04 UTC
This incident affected: Netlify Image CDN.