Stuck cancelled builds
Incident Report for Netlify
Resolved
We have cancelled all remaining stuck builds and do not expect recurrence.
Posted Oct 31, 2023 - 16:38 UTC
Monitoring
We've fixed the root cause and are working to preemptively cancel any stuck builds. Customers may self-serve on cancelling these builds via our UI using the "Cancel deploy" button and new builds will go through as intended.
Posted Oct 31, 2023 - 16:22 UTC
Identified
Some customers who use our ignore builds feature may have had builds get stuck since 9:11 UTC. Our team has applied a fix so new builds should not get stuck and are working to remediate existing stuck builds. If you have a stuck build, hit the "Cancel deploy" button in our UI to unblock yourself, otherwise any stuck builds will time out soon.
Posted Oct 31, 2023 - 16:10 UTC
This incident affected: Build Pipeline.