Impacted DNS & Domain Management
Incident Report for Netlify
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 01:50 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2020 - 01:39 PST
Investigating
We are currently investigating an issue which is impacting Netlify DNS domain management, wildcard Let's Encrypt certificate issuing and domain orders.
Posted Nov 16, 2020 - 01:01 PST
This incident affected: Hosted DNS.