Issue preventing adding new sites via the web app
Incident Report for Netlify
Resolved
We resolved an issue that prevented adding new sites via the web app between 15:42 and 18:17 UTC on 2024-03-22. The issue has been resolved and sites can be added again now.
Posted Mar 22, 2024 - 15:42 UTC