Increased errors on HP Edge Network

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 12:39 UTC

Monitoring

We have identified the cause, implemented a fix, and are now monitoring results.
Posted Sep 02, 2025 - 12:28 UTC

Investigating

We see an increase in errors serving content on HP Edge across several regions starting at 12:15 UTC.
Posted Sep 02, 2025 - 12:26 UTC
This incident affected: High-Performance Edge Network.