The Netlify Application UI is down

Incident Report for Netlify

Resolved

The incident is resolved.
Posted May 15, 2025 - 23:54 UTC

Monitoring

The root cause has been identified and a solution has been implemented. We are monitoring to confirm the resolution.
Posted May 15, 2025 - 23:44 UTC

Investigating

The app.netlify.com site is down. Hosted sites are not impacted. We are working to identify the cause now.
Posted May 15, 2025 - 23:32 UTC
This incident affected: Netlify Application UI.