Increased latency on High Performance Edge Network in São Paulo

Incident Report for Netlify

Resolved

The latencies should be back to normal as of 18:10 UTC.
Posted Dec 03, 2025 - 18:22 UTC

Investigating

Starting 17:54 UTC we see increased latency for traffic on the High Performance Edge in the São Paulo region. We're currently investigating this issue.
Posted Dec 03, 2025 - 18:09 UTC
This incident affected: High-Performance Edge Network.