Deploy, Function, and Edge Function Logs Access Issue

Incident Report for Netlify

Resolved

The incident has been resolved, and we are no longer observing any issues. Thank you for your patience.
Posted Oct 08, 2025 - 12:30 UTC

Monitoring

We’ve implemented a fix and are observing recovery in log access. Our team is continuing to monitor the situation to ensure stability.
Posted Oct 08, 2025 - 12:15 UTC

Investigating

We’re investigating an issue causing errors or missing data when accessing deploy, function, and Edge function logs.
Posted Oct 08, 2025 - 11:42 UTC
This incident affected: Build Pipeline, Netlify Functions, and Edge Functions.