Delayed Cache Purges

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 01:32 UTC

Monitoring

We experienced an increased number of delayed cache purges on both the Standard and HP Edge Networks between 22:30 and 0:10 UTC. We have deployed a fix and are currently monitoring the results.
Posted Mar 24, 2026 - 00:30 UTC
This incident affected: High-Performance Edge Network, Standard Edge Network, and Agent Runners.