Domain purchasing currently unavailable

Incident Report for Netlify

Resolved

Domain purchasing has been restored.
Posted May 09, 2025 - 08:17 UTC

Identified

We have identified the issue and are implemented a fix.
Posted May 08, 2025 - 15:00 UTC

Investigating

We are currently experiencing issues with the purchasing of new domain names. Domain renewals are unaffected.
Posted May 08, 2025 - 14:24 UTC
This incident affected: Domain Purchasing.