Builds did not start
Incident Report for Netlify
Postmortem

On October 16, 2021 from 8:21 UTC we noticed a problem with our build system. Some Git-based deploys appeared to be stuck and reported only Build ready to start in the build log for some time until:

  1. They either resumed themselves.
  2. Or, they were cancelled and a re-deploy was triggered - some of which could again suffer the same fate.

We would like to apologise for the inconvenience this would have caused to the affected users. We also could not update the status page as it happened which added to the problem. The team is aware of this issue and is working hard to prevent such issues in the future. We hope you understand and continue building your great projects with Netlify!

By 11:35 UTC, the issue was fixed. The builds would now either auto-resume or would work fine if they were re-triggered. Some of the users who reported this issue in our helpdesk and forums have now confirmed that it’s working as good as before now.

If you’re still seeing something wrong, feel free to write on our forums or in the helpdesk if you’re a Pro or above user and we’d be happy to help!

Posted Oct 16, 2021 - 12:06 UTC

Resolved
We identified and resolved an incident which was causing a delay for builds to start. This affected some Git-based deploys. For any builds that might still appear stuck, a cancellation and re-trigger should fix it.
Posted Oct 16, 2021 - 08:21 UTC