Failing builds for deploys that contain scheduled functions
Incident Report for Netlify
Resolved
New deploys using scheduled functions may still not work for some users, and the team is working to create a more stable fix for this beta feature in the next couple of days. We'll post further updates as the fix develops, in our forums in this thread: https://answers.netlify.com/t/scheduled-functions-crashes-deploys/53174
Posted Mar 09, 2022 - 20:10 UTC
Identified
New deploys since 14:18 UTC which attempt to deploy scheduled functions have failed. Older deploys using scheduled functions will continue to work as expected. If you need to deploy a new copy of your site that uses scheduled functions while our team works on a fix, you will need to remove scheduled functions from your code. We are working on a smoother way to disable the feature than a code change and will report back when that is available.
Posted Mar 09, 2022 - 19:18 UTC
Investigating
We are investigating reports of builds failing on sites that use scheduled functions. To mitigate, please temporarily disable or remove the scheduled functions to continue building.
Posted Mar 09, 2022 - 19:05 UTC
This incident affected: Build Pipeline and Netlify Functions.