Extension Service Experiencing Timeouts

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 18:56 UTC

Investigating

Starting at 17:00 UTC, customers using extensions in the UI may see errors or be unable to load extensions or their configuration pages. We are currently investigating this issue.
Posted Jun 09, 2025 - 18:37 UTC
This incident affected: Netlify Application UI.