Support Communication Delivery Issues

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted May 25, 2026 - 17:32 UTC

Monitoring

outbound email delivery has been restored and emails are now processing successfully. Some delays may continue while queued messages are delivered. We are continuing to monitor the recovery closely
Posted May 25, 2026 - 15:53 UTC

Identified

We are currently investigating an issue affecting outbound email delivery for some Netlify services, including support-related communications. Our team is working with our email provider to restore service as quickly as possible
Posted May 25, 2026 - 15:31 UTC
This incident affected: Netlify Helpdesk.