Payment collection issues for some non-US customers.

Incident Report for Netlify

Resolved

Working with our 3rd party billing partner, we have found and resolved the ongoing issue with collecting payments from some customers outside the U.S.
Posted Jul 31, 2025 - 21:36 UTC

Identified

we have identified an issue with our 3rd party billing partner, and are currently working towards a resolution
Posted Jul 31, 2025 - 19:17 UTC

Investigating

We are currently investigating issues with collecting payments from some customers outside of the US.
Posted Jul 31, 2025 - 13:35 UTC
This incident affected: Billing.