Elevated Errors in IAD region

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted May 08, 2026 - 04:00 UTC

Investigating

We're seeing an increased level of errors in the IAD region starting around 02:10 UTC for both our Standard and HP Edge Networks due to an upstream issue at AWS: https://health.aws.amazon.com/health/status.
Posted May 08, 2026 - 02:53 UTC
This incident affected: High-Performance Edge Network and Standard Edge Network.