Increased errors & latency in serving traffic on High Performance Edge Network

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 14:26 UTC

Update

We are continuing to monitor our mitigations and for any further issues.
Posted Nov 28, 2025 - 13:40 UTC

Monitoring

We are continuing to monitor the recovery results across the network.
Posted Nov 28, 2025 - 13:02 UTC

Update

We are continuing to see recovery across the network
Posted Nov 28, 2025 - 12:55 UTC

Identified

We have applied a mitigation and are seeing recovery.
Posted Nov 28, 2025 - 12:44 UTC

Update

We are continuing to investigate this issue
Posted Nov 28, 2025 - 12:34 UTC

Investigating

As of 12:04 UTC, we are experiencing issues and latency serving traffic from the High Powered Edge Network.
Posted Nov 28, 2025 - 12:19 UTC
This incident affected: High-Performance Edge Network.