Increased Latency in API & Builds

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted May 12, 2026 - 15:38 UTC

Monitoring

We have implemented a fix and are monitoring system performance to ensure services continue to recover as expected.
Posted May 12, 2026 - 15:20 UTC

Investigating

We are currently investigating increased latency affecting our API and build systems. Some users may experience slower-than-normal response times for API requests and builds while we work to identify the source of the issue.
Posted May 12, 2026 - 14:30 UTC
This incident affected: Build Pipeline and API.