We are continuing to monitor for any further issues.
Posted Mar 11, 2026 - 11:19 UTC
Monitoring
The cause of the issue was identified, and we are monitoring the fix that was applied.
Posted Mar 11, 2026 - 10:57 UTC
Update
We are continuing to investigate this issue.
Posted Mar 11, 2026 - 10:33 UTC
Update
We are continuing to investigate this issue
Posted Mar 11, 2026 - 10:08 UTC
Investigating
We continue to investigate this rise in latencies creating high error rates.
Posted Mar 11, 2026 - 09:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2026 - 09:09 UTC
Identified
The issue has been identified and we are working on a resolution.
Posted Mar 11, 2026 - 08:49 UTC
Investigating
We are experiencing high latencies in our origin. This may cause high error rates and elevated response times, as well as build failures. We are currently investigating.
Posted Mar 11, 2026 - 08:44 UTC
This incident affected: Build Pipeline, Netlify Application UI, and API.