Increased Image CDN latency

Incident Report for Netlify

Resolved

After monitoring we have confirmed we are no longer seeing high latency.
Posted Jun 18, 2025 - 14:52 UTC

Monitoring

We have noticed error rates and latency have fallen, we are currently monitoring
Posted Jun 18, 2025 - 14:30 UTC

Investigating

We are currently investigating reports of issues with our ImageCDN.
Posted Jun 18, 2025 - 13:54 UTC
This incident affected: Netlify Image CDN.