Degraded performance with Create API

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted May 19, 2026 - 20:41 UTC

Monitoring

We have resolved the issue causing elevated error rates in the Create API. Systems are now recovering, and we are monitoring closely.
Posted May 19, 2026 - 20:23 UTC

Investigating

Investigating: We’re seeing degraded performance with create.netlify.com. Some customers are seeing issues with latency or 500 errors while accessing the create.netlify.com
Posted May 19, 2026 - 18:18 UTC
This incident affected: Netlify Create API.