Elevated error rates for a subset of sites using Edge Functions

Incident Report for Netlify

Resolved

This incident has been resolved. Between approximately 17:00 and 20:30 UTC, a subset of sites using Edge Functions experienced elevated 504 error rates. We applied a mitigation and error rates have remained at normal levels since. We apologize for  the impact to your sites and visitors.
Posted Jun 04, 2026 - 20:59 UTC

Monitoring

We have applied a mitigation and error rates for affected sites have returned to normal levels as of approximately 20:30 UTC. We are continuing to monitor the situation and will provide a final update once we have confirmed full recovery
Posted Jun 04, 2026 - 20:42 UTC

Identified

We have identified an issue with a subset of our Edge Functions infrastructure causing elevated 504 errors for some sites beginning at approximately 17:00 UTC. We are applying mitigations and error rates are improving. Customers do not need to take any action. We will continue to provide updates here.
Posted Jun 04, 2026 - 20:34 UTC

Investigating

Our team is investigating an increase in observed error rates affecting a subset of sites that use Edge Functions. Affected sites may see elevated 504 responses or slow page loads beginning at approximately 17:00 UTC. We are actively working to  identify the cause and will provide updates here.
Posted Jun 04, 2026 - 20:24 UTC
This incident affected: Edge Functions.