Issue with adding new payment methods

Incident Report for Netlify

Resolved

After monitoring the applied fix, we can confirm this issue resolved.
Posted May 26, 2025 - 17:05 UTC

Monitoring

A fix has been implemented, this is now resolved. We will continue to monitor.
Posted May 26, 2025 - 16:47 UTC

Identified

We are working with our backend provider we have identified the issue and are rolling out a fix.
Posted May 26, 2025 - 16:08 UTC

Update

We are continuing to investigate the issue with adding new cards in the UI.
Posted May 26, 2025 - 15:31 UTC

Investigating

We are currently experiencing difficulties with adding new credit cards in the UI.
Posted May 26, 2025 - 14:45 UTC
This incident affected: Netlify Application UI.