Detected ongoing issue using Git Gateway with GitLab repositories
Incident Report for Netlify
Resolved
We are no longer seeing any failing requests. Resolving this incident. Thank you for your patience.
Posted Nov 19, 2019 - 02:47 PST
Monitoring
We have mitigated the issue with Git Gateway on GitLab. Our team narrowed down the issue to a specific HTTP header that caused the GitLab servers to falsely detect a spoofing attack. This feature should now be fully functional. We will continue to monitor requests and will resolve the incident after we've confirmed the issue is resolved.
Posted Nov 19, 2019 - 02:16 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway: many CMS-driven actions for Netlify-hosted CMS operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated. We'll update this notice only when status changes, which is not expected before Monday 18 Nov.
Posted Nov 16, 2019 - 12:07 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway, affecting all CMS-driven actions for Netlify-hosted CMS operations; most operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated.
Posted Nov 16, 2019 - 06:32 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway, affecting all CMS-driven actions for Netlify-hosted CMS operations; most operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated.
Posted Nov 16, 2019 - 02:32 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway, affecting all CMS-driven actions for Netlify-hosted CMS operations; most operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated.
Posted Nov 15, 2019 - 22:38 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway, affecting all CMS-driven actions for Netlify-hosted CMS operations; most operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated.
Posted Nov 15, 2019 - 17:46 PST
Update
Service remains degraded for (only) GitLab-backed Git Gateway, affecting all CMS-driven actions for Netlify-hosted CMS operations; most operations will fail. Additionally, Git Gateway setups using other providers that were created between 0245 and 1923 UTC Friday 15 Nov will need to be recreated.
Posted Nov 15, 2019 - 13:32 PST
Update
Git Gateway is now operational for customers using GitHub and BitBucket repositories. We are continuing to work on mitigating the issue for GitLab users.
Posted Nov 15, 2019 - 11:35 PST
Update
The issue with Git Gateway has expanded to all providers including GitHub and BitBucket. We are investigating restoring access, and more information will be available in 30 minutes.
Posted Nov 15, 2019 - 10:44 PST
Update
Our team is continuing to work on resolving the issue. We will provide more information as they become available.
Posted Nov 15, 2019 - 09:03 PST
Update
To provide more context: some requests to GitLab are failing, while some requests do succeed after retrying. Our team continues to work on resolving the issue.
Posted Nov 15, 2019 - 07:58 PST
Update
We continue to investigate the cause of this Git Gateway issue and working to mitigate it. We'll update this incident as we make progress.
Posted Nov 15, 2019 - 06:27 PST
Update
We are continuing to work on mitigating the issue. We'll also keep this incident updated as we make progress.
Posted Nov 15, 2019 - 05:03 PST
Identified
We have identified an issue with Git Gateway not working for GitLab repositories. The issue does not affect using Git Gateway with GitHub or BitBucket repositories. We will update with more information as soon as they are available.
Posted Nov 15, 2019 - 04:07 PST
This incident affected: Git Gateway.