502 Errors on app.netlify.com

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 00:05 UTC

Update

We're continuing to investigate this issue and are beginning to see some services recovering.
Posted Jun 12, 2025 - 20:23 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:51 UTC

Update

We're currently experiencing an increase in 502 errors and issues accessing app.netlify.com. We're investigating a potential issue with Google Cloud Platform, one of our upstream providers.
Posted Jun 12, 2025 - 18:43 UTC

Investigating

We're currently experiencing an increase in 502 errors and issues accessing app.netlify.com. We're currently investigating this issue.
Posted Jun 12, 2025 - 18:23 UTC
This incident affected: Build Pipeline, Netlify Application UI, Log Drains, and Netlify Forms.