Email delivery backlog
Incident Report for Netlify
Resolved
We've delivered all backlogged form submission notifications, but not other emails such as deploy status notifications and billing reminders which would not be useful after a time delay. Please sound off in this forums thread: https://answers.netlify.com/t/email-delivery-delays-from-27-sep-2021/44777 , if you haven't seen some email from our system that you were expecting on Monday between 1600 and 2040 UTC.
Posted Sep 29, 2021 - 23:34 UTC
Monitoring
Transactional emails are again being delivered, but most mails generated between 1600 UTC and 2045 UTC today have not yet been delivered and we do not have a firm timeline for their delivery, though we do expect it in coming hours. Please see https://answers.netlify.com/t/email-delivery-delays-from-27-sep-2021/44777 for more details about effects and how to get more help if needed.
Posted Sep 27, 2021 - 21:00 UTC
Investigating
Investigating: Netlify's transactional emails are not being delivered since approximately 1600 UTC. This will impact password resets, signups, billing emails, and all other email-based notifications such as form responses and deploy notifications. Only emails are paused; all features are otherwise working correctly so we are not losing form responses or failing to perform deploys.
Posted Sep 27, 2021 - 19:00 UTC
This incident affected: API.