Increased Latency with Edge Functions

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 13:36 UTC

Monitoring

We see an increased latency and errors invoking in Edge Functions on HP Edge starting at 12:38 UTC. This has recovered by 12:44 UTC. Our team is monitoring.
Posted Dec 15, 2025 - 12:55 UTC
This incident affected: High-Performance Edge Network and Edge Functions.