Increased errors and latencies in Netlify UI

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 16:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2026 - 16:03 UTC

Investigating

We're currently experiencing increased errors and latencies in the Netlify UI. We are investigating the problem.
Posted Jan 26, 2026 - 15:52 UTC
This incident affected: Netlify Application UI.